Device compatibility

For optimal performance, we recommend using the most up-to-date version of any operating system, browser, and app.

 

Currently, Nearpod supports a wide variety of devices through our applications and web browsers. These include, but are not limited to --

  • All computers capable of using the latest iteration of the Google Chrome web browser.
  • iOS devices (iPhones, iPads, iPod touch) running iOS version 13.0 or newer. 
  • Mac OS devices using OS 10 or newer with Safari browser
  • Android handheld devices running version 5.0 or newer (recommended 6.0 for Google play store app)
  • Chromebooks running the latest version of Chrome OS

We always recommend using the latest version of the application available for your device. 

While these devices are guaranteed to work, many others can be used with their built in web browsers such as Kindle Fires and Android devices running builds older than 5.0.

 

If you have specific questions about device compatibility please don't hesitate to reach out to our support team via support@nearpod.com

***Please note that the VR and 3d image capabilities (in terms of full functionality) are limited to the latest builds of the application on the newest versions of iOS. Most devices can still view the Virtual field trip images by panning with touch input.



Have a suggestion? Click here to tell us how to make Nearpod even better.
Powered by Zendesk