Are there any browsers extensions needed for Nearpod?

No browser extensions are nedeed. To have the best Nearpod experience, please make sure you're using an up-to-date browser. See minimum requirements below:

Chrome version 40 or greater
Firefox version 25 or greater
Internet Explorer version 10 or greater
Safari version 6 or greater
Opera version 26 or greater

Have more questions? Submit a request
Powered by Zendesk