Post

2 followers Follow
0
Avatar

System Requirements

What are the system requirements for Nearpod?

Thank You

gonzicovos

Official comment

Avatar

To use Nearpod you will need at least 1 iPad for the instructor and either iPads, iPods, iPhones (at least iOS 7.0) or Android devices (at least 4.0 version) for each student. Also, each device must be able to connect to the internet.

Melisa Bebchik

Please sign in to leave a comment.

1 comment